Skip to content
rdptech's profile

Visitor

 • 

3 Messages

Sun, Feb 9, 2020 10:00 AM

VPN access using L2TP/IPSEC stopped working on SMC d3g router

I have been using both pptp and l2tp to connect from a remote location into my office network, through an SMC d3g comcast router. No setting changes have been made to it, yet L2tp just stopped working sometime during the last week of november 2019.  PPTP still works fine.

 

I have investigated this throroughly by using different remote computers, and contacting technical support of my server machine for additional assistance (no server issue was found).  I can connect to the L2TP server through a computer on the internal network without issue.  So something on the router or internet is blocking the connection of this protocol (ports 500, 4500, 1701).

 

In addition, I use remote wake on lan (using port 9)  to remotely power up a computer on the internal network, which also stopped working recently.  However it does work when I am internal to the network.

 

What can I do to fix these issues, or is comcast blocking these services?

Responses

Accepted Solution

Official Employee

 • 

401 Messages

1 y ago

Sure! Click on my handle (Comcast_Gina) and it should give you the option to send a private message. If you can provide your name, the business name, the complete service address (including city, state, ZIP, suite number, etc), and the phone or account number, we'll be glad to get you scheduled for the modem upgrade 🙂 

Accepted Solution

Visitor

 • 

3 Messages

1 y ago

The modem upgrade solved all of the problems.  And the firewall is configurable, so the information in the above response was incorrect.

Official Employee

 • 

518 Messages

1 y ago

Thanks so much for taking the time to reach out to us through our business forums and I appreciate your patience as you waited for a response. Most of what you are describing here is beyond our line of demarcation or outside the scope of our services. As internal networks vary so drastically from business to business, I can only provide my expertise for our equipment or wiring. To review the ports that we are blocking on our network just click on this link, https://comca.st/2HahHJa The model of modem that you are currently using is a older model modem, that we are no longer using with our business services. You might consider an upgrade to the modem, if you would like more information on getting this set up please reach out through private message with your first and last name, full-service address and account number or phone number and we will get this process going for you.  Are you using static Ip's with the services?

Visitor

 • 

3 Messages

1 y ago

That was an interesting answer as the problem IS external, not internal.  As I described, I can access these servers and devices inside the internal network, but cannot access them through the SMC router (although it used to work fine until end of November 2019).

 

Yes all services are using static IPs.

 

I will consider upgrading the modem.  Can you tell me where I go to send a private message to requrest this?

New problem solver

 • 

13 Messages

1 y ago

From the "well somebody should tell him" department...

 

Unless something changed very recently, the replacement modem you get won't even have option (pretty sure vpn settings in the the SMC's comcast firmware was an accident).  You will also lose the undocumented hybrid bridge mode (or whatever it's called), which was a killer for me because unlike VPN there is no way to duplicate the behavior with customer owned equipment.  

Official Employee

 • 

238 Messages

1 y ago

Hey there! Thank you so much for your patience and for providing this feedback! I will make sure to pass along your feedback. Do you have any additional questions or concerns for me this evening?

Official Employee

 • 

401 Messages

1 y ago

Hooray! I'm so glad to hear that the modem swap did the trick 🙂 If there is anything else that you need in the future, this community is always here to help and we really appreciate you being part of it!

New problem solver

 • 

13 Messages

1 y ago

I didn't say the firewall wouldn't be configurable, I said unless something changed recently it wouldn't be configurable as a VPN endpoint.  

Official Employee

 • 

137 Messages

1 y ago

I'll definitely look into that for you if needed. In your previous reply, you mentioned the modem upgrade solved the problem. Do you have any further concerns I can help you with? -Rob K. 

Visitor

 • 

3 Messages

1 y ago

Same issue as you...did your upgrade include Comcast swapping out the modem or just a firmware upgrade?

Official Employee

 • 

518 Messages

1 y ago

Thanks for taking the time to reach out to us through our business forums. I am sorry to hear that you are having these connection issues and for the delay in our response. Can you please reach out through private message with your first and last name, full service address and account number or phone number?